summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kshowmail/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-05-05 02:42:38 +0200
committerSlávek Banko <[email protected]>2019-05-05 02:43:14 +0200
commit57d58eb0ab774d2e1689d98bcff2fc35e0940606 (patch)
treec7aa6c10798b1fc73fd54e65de6580941824ff78 /ubuntu/_base/applications/kshowmail/debian/rules
parent17012e1505323967184a98a28da8bbe8b1a8762a (diff)
downloadtde-packaging-57d58eb0ab774d2e1689d98bcff2fc35e0940606.tar.gz
tde-packaging-57d58eb0ab774d2e1689d98bcff2fc35e0940606.zip
DEB kshowmail: Switch to cmake.
Add basic package documentation. The man page has been moved to the main tree. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit ded8dc0c76e59ed36c14f7a8705aa02b4d33ee0c)
Diffstat (limited to 'ubuntu/_base/applications/kshowmail/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kshowmail/debian/rules46
1 files changed, 11 insertions, 35 deletions
diff --git a/ubuntu/_base/applications/kshowmail/debian/rules b/ubuntu/_base/applications/kshowmail/debian/rules
index 4d2e210a8..0f312cb4c 100755
--- a/ubuntu/_base/applications/kshowmail/debian/rules
+++ b/ubuntu/_base/applications/kshowmail/debian/rules
@@ -1,40 +1,16 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-binary-install/kshowmail-trinity::
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"