summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/multimedia/k9copy/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2023-08-04 16:26:58 +0900
committerMichele Calgaro <[email protected]>2023-08-06 17:11:17 +0900
commit7bec44d125b777856ef1a48eecdd76c3c386200d (patch)
treedd60239e3c6202225c18d66b4b36712d938816ef /ubuntu/_base/applications/multimedia/k9copy/debian/rules
parentbbfa80f7f281c76c2aa5c053d0ec9eb23926b02b (diff)
downloadtde-packaging-7bec44d125b777856ef1a48eecdd76c3c386200d.tar.gz
tde-packaging-7bec44d125b777856ef1a48eecdd76c3c386200d.zip
DEB k9copy: conversion to cmake build system
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 9e00adb4a2baf2b7c961358cbc228a20d388622a)
Diffstat (limited to 'ubuntu/_base/applications/multimedia/k9copy/debian/rules')
-rwxr-xr-xubuntu/_base/applications/multimedia/k9copy/debian/rules37
1 files changed, 12 insertions, 25 deletions
diff --git a/ubuntu/_base/applications/multimedia/k9copy/debian/rules b/ubuntu/_base/applications/multimedia/k9copy/debian/rules
index 6219a645e..a6797f19a 100755
--- a/ubuntu/_base/applications/multimedia/k9copy/debian/rules
+++ b/ubuntu/_base/applications/multimedia/k9copy/debian/rules
@@ -1,30 +1,17 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --includedir="/opt/trinity/include/tde" --mandir="/opt/trinity/share/man" --infodir="/opt/trinity/share/info" --enable-k3bdevices
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"