summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/system/polkit-agent-tde/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2022-01-29 19:36:58 +0900
committerMichele Calgaro <[email protected]>2022-01-29 19:40:56 +0900
commitad7b992aff7f7fe57be4b237a8c66ec610a0ebf7 (patch)
treea6d665c9da22ee880f9b672f92c9365ee3abc24a /ubuntu/_base/applications/system/polkit-agent-tde/debian/rules
parent11bc93a01c7362269f4a6806224f7e5b7636e2dd (diff)
downloadtde-packaging-ad7b992aff7f7fe57be4b237a8c66ec610a0ebf7.tar.gz
tde-packaging-ad7b992aff7f7fe57be4b237a8c66ec610a0ebf7.zip
DEB: added packaging files for polkit-agent-tde
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 29e92d5328a72b1188ce6bf32fadd2407ad128cd)
Diffstat (limited to 'ubuntu/_base/applications/system/polkit-agent-tde/debian/rules')
-rwxr-xr-xubuntu/_base/applications/system/polkit-agent-tde/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/system/polkit-agent-tde/debian/rules b/ubuntu/_base/applications/system/polkit-agent-tde/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/ubuntu/_base/applications/system/polkit-agent-tde/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"