summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqt3/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-06-20 12:51:50 +0900
committerMichele Calgaro <[email protected]>2024-06-25 19:28:20 +0900
commit355bec7df1f2dde81834eca7b7c979dd461acbea (patch)
tree6db7c5a17de9c7486c1af40abc1c10312be08936 /ubuntu/_base/dependencies/tqt3/debian/rules
parentcf2b2717c3c6b71ee78932ff75f7090cc35579e1 (diff)
downloadtde-packaging-355bec7df1f2dde81834eca7b7c979dd461acbea.tar.gz
tde-packaging-355bec7df1f2dde81834eca7b7c979dd461acbea.zip
DEB tqt3: remove Qt/embedded related files
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'ubuntu/_base/dependencies/tqt3/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqt3/debian/rules14
1 files changed, 1 insertions, 13 deletions
diff --git a/ubuntu/_base/dependencies/tqt3/debian/rules b/ubuntu/_base/dependencies/tqt3/debian/rules
index 36a8cc408..f42f8989d 100755
--- a/ubuntu/_base/dependencies/tqt3/debian/rules
+++ b/ubuntu/_base/dependencies/tqt3/debian/rules
@@ -191,10 +191,6 @@ libqt-thread-stamp: post-patches
cd tools/designer/tools/tqtconv2ui && $(MAKE)
cp bin/tqtconv2ui $(TMP_INSTALL)/usr/bin/tqtconv2ui
- # build tqvfb
- cd tools/tqvfb/ && $(MAKE)
- cp tools/tqvfb/tqvfb $(TMP_INSTALL)/usr/bin/tqvfb
-
# install qmake.cache file
install -d $(P_QTMTDEV)/usr/share/tqt3/
cat .qmake.cache | sed "s#$(QTDIR)#/usr/share/tqt3#g" > $(P_QTMTDEV)/usr/share/tqt3/.qmake.cache
@@ -213,7 +209,7 @@ clean::
if [ -f "src/Makefile" ]; then \
$(MAKE) -C src clean; $(MAKE) -C plugins/src distclean; $(MAKE) -C tools distclean; \
- $(MAKE) -C tools/maketqpf distclean; $(MAKE) -C tools/qconfig distclean; $(MAKE) -C tools/tqvfb distclean; \
+ $(MAKE) -C tools/qconfig distclean; \
$(MAKE) -C tools/msg2tqm distclean; $(MAKE) -C tools/tqtmergetr distclean; $(MAKE) -C tools/qembed distclean; \
$(MAKE) -C tools/designer/tools/tqtconv2ui distclean; $(MAKE) -C tools/designer/tools/tqtcreatecw distclean; \
$(MAKE) -C tools/designer/plugins/glade distclean; $(MAKE) -C tools/designer/plugins/qglwidget distclean; \
@@ -403,11 +399,6 @@ binary-arch: build install
cp `pwd`/tools/designer/editor/*.h $(P_APPSDEV)/usr/include/tqt3/
rm -rf `pwd`/debian/tqt3-apps-dev/usr/include/tqt3/preferences.ui.h
- ## tqvfb package
- install -m644 -D `pwd`/tools/tqvfb/pda.skin `pwd`/debian/tqt3-dev-tools-embedded/etc/tqt3/tqvfb/pda.skin
- install -m644 -D `pwd`/tools/tqvfb/pda_down.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/tqvfb/pda_down.png
- install -m644 -D `pwd`/tools/tqvfb/pda_up.png `pwd`/debian/tqt3-dev-tools-embedded/usr/share/tqvfb/pda_up.png
-
# remove utterly ugle symlink
rm -rf `pwd`/debian/tqt3-dev-tools//usr/share/tqt3/mkspecs/linux-g++/linux-g++
@@ -502,9 +493,6 @@ binary-arch: build install
# fix shlibdeps madness
for a in `find debian/ -name '*.substvars'`; do cat "$$a" | sed 's/, xlibs (>> 4.1.0)//g' > "$$a".new && mv "$$a.new" "$$a"; done
- # fix conffiles file for tqt3-dev-tools-embedded
- echo "/etc/tqt3/tqvfb/pda.skin" > `pwd`/debian/tqt3-dev-tools-embedded/DEBIAN/conffiles
-
dh_gencontrol -a $(IBASE)
dh_md5sums -a $(IBASE)
dh_builddeb -a $(IBASE) $(DEB_DH_BUILDDEB_ARGS)