summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2012-09-10 09:07:43 -0500
committerTimothy Pearson <[email protected]>2012-09-10 09:07:43 -0500
commit1468145eb5c3a6e4906320c7b2e86b9ac07ce675 (patch)
tree09b0cdc52e9d93a2505e5ec4f8dddb501a0440f9 /ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk
parent56b1a06ec007819b9d45e7c7e1e0df2f3371f03c (diff)
downloadtde-packaging-1468145eb5c3a6e4906320c7b2e86b9ac07ce675.tar.gz
tde-packaging-1468145eb5c3a6e4906320c7b2e86b9ac07ce675.zip
Add initial knetworkmanager9 packaging files
Diffstat (limited to 'ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk')
-rw-r--r--ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/maverick/applications/knetworkmanager9/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <[email protected]>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "[email protected]" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders