summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
diff options
context:
space:
mode:
authorFrancois Andriot <[email protected]>2013-01-03 22:47:53 +0100
committerFrancois Andriot <[email protected]>2013-01-03 22:47:53 +0100
commitd2f32337f00cf98faef8475e769d9c0381efd257 (patch)
tree9890ceb134945c4f24e624dca8ac4fa03888a979 /ubuntu/maverick/dependencies/avahi-tqt/debian/rules
parentb566058ccb7fa94c6e34fb1e1349b093d4482d6a (diff)
parentfe7329f1eaa98f63b62e23449bb1345b3395ed37 (diff)
downloadtde-packaging-d2f32337f00cf98faef8475e769d9c0381efd257.tar.gz
tde-packaging-d2f32337f00cf98faef8475e769d9c0381efd257.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/dependencies/avahi-tqt/debian/rules')
-rwxr-xr-xubuntu/maverick/dependencies/avahi-tqt/debian/rules17
1 files changed, 12 insertions, 5 deletions
diff --git a/ubuntu/maverick/dependencies/avahi-tqt/debian/rules b/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
index c3ea0343f..54a22a44f 100755
--- a/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
+++ b/ubuntu/maverick/dependencies/avahi-tqt/debian/rules
@@ -1,17 +1,24 @@
#!/usr/bin/make -f
-%:
- dh $@
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
# Ensure at build time that the library has no dependencies on undefined
# symbols, and speed up loading.
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
-override_dh_auto_configure:
- ./autogen.sh
- dh_auto_configure -- $(CONFFLAGS) \
+DEB_CONFIGURE_EXTRA_FLAGS += \
--enable-compat-libdns_sd \
--disable-mono --disable-monodoc \
--disable-gtk3 \
--with-systemdsystemunitdir=/lib/systemd/system
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ./autogen.sh
+ rm ./ChangeLog
+ touch debian/stamp-bootstrap