summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/applications/klcddimmer/debian/rules
diff options
context:
space:
mode:
authorFrançois Andriot <[email protected]>2013-08-27 21:17:52 +0200
committerFrançois Andriot <[email protected]>2013-08-27 21:17:52 +0200
commit1af57210e2e55d40eb39a274fcf48779c6b9e7d5 (patch)
tree55c22bbd35462f1c940b24614af05ea07bcd7f35 /ubuntu/raring/applications/klcddimmer/debian/rules
parentaf8c5ead9ac4c1ece3408b74224e5e273b6994ce (diff)
parent2d0d0ba99b507cab093962cb910ddc7dd4755c94 (diff)
downloadtde-packaging-1af57210e2e55d40eb39a274fcf48779c6b9e7d5.tar.gz
tde-packaging-1af57210e2e55d40eb39a274fcf48779c6b9e7d5.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/raring/applications/klcddimmer/debian/rules')
-rwxr-xr-xubuntu/raring/applications/klcddimmer/debian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/ubuntu/raring/applications/klcddimmer/debian/rules b/ubuntu/raring/applications/klcddimmer/debian/rules
new file mode 100755
index 000000000..55935a695
--- /dev/null
+++ b/ubuntu/raring/applications/klcddimmer/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ dh_testdir
+
+ # Regenerate build system
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ autoreconf --install && automake -f && \
+ $(MAKE) -f admin/Makefile.common && \
+ touch debian/stamp-bootstrap
+
+clean::
+ dh_testdir
+ rm -f debian/stamp-bootstrap