summaryrefslogtreecommitdiffstats
path: root/deco/Makefile.am
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2021-10-01 14:38:07 +0200
committergregory guy <[email protected]>2021-10-01 14:38:07 +0200
commit8648781af8e31b5b243e26a7ae42b36b38aa8aed (patch)
treeebd958c73958b45afb7cc6c053ccf9801b97f3b0 /deco/Makefile.am
parenta5e262a67d56ccb85f8df78d3d1b1b27e889d790 (diff)
downloadtde-style-baghira-8648781af8e31b5b243e26a7ae42b36b38aa8aed.tar.gz
tde-style-baghira-8648781af8e31b5b243e26a7ae42b36b38aa8aed.zip
Drop automake build support.
Deleted TODO and NEWS empty files. Rework of the README file. Add basic cmake build instructions. Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'deco/Makefile.am')
-rw-r--r--deco/Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/deco/Makefile.am b/deco/Makefile.am
deleted file mode 100644
index 9931018..0000000
--- a/deco/Makefile.am
+++ /dev/null
@@ -1,28 +0,0 @@
-AUTOMAKE_OPTIONS = foreign
-
-SUBDIRS = config
-
-KDE_CXXFLAGS = -DQT_PLUGIN
-
-INCLUDES = $(all_includes) -I$(kde_includes)/twin
-
-twindir = $(kde_datadir)/twin/
-twin_DATA = baghira.desktop
-
-EXTRA_DIST = $(twin_DATA) images
-
-noinst_HEADERS = baghiraclient.h pixmaps.h masks.h
-
-kde_module_LTLIBRARIES = twin3_baghira.la
-twin3_baghira_la_SOURCES = baghiraclient.cpp
-twin3_baghira_la_LIBADD = $(kde_libraries)/libtdecorations.la
-twin3_baghira_la_LDFLAGS = $(all_libraries) $(LIB_TQT) $(KDE_PLUGIN) $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx -module
-twin3_baghira_la_METASOURCES = AUTO
-
-DISTCLEANFILES = $(twin3_baghira_la_METASOURCES)
-
-pixmaps.h: $(srcdir)/generatePixmaps.sh
- $(SHELL) $(srcdir)/generatePixmaps.sh $(top_srcdir)
-CLEANFILES = pixmaps.h
-baghiraclient.lo: pixmaps.h
-