summaryrefslogtreecommitdiffstats
path: root/src/gtk/engine/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2024-03-10 18:36:50 +0200
committerTDE Gitea <[email protected]>2024-03-28 15:13:46 +0000
commitbf94b5f4d80f9bdcc70d929664d935b56c324c85 (patch)
tree9e52bc5d5853c9959d8f16060f394588e2138f0d /src/gtk/engine/CMakeLists.txt
parentbb0a8ec627425405bae2c4289c14ef12ca525e86 (diff)
downloadtde-style-ia-ora-bf94b5f4d80f9bdcc70d929664d935b56c324c85.tar.gz
tde-style-ia-ora-bf94b5f4d80f9bdcc70d929664d935b56c324c85.zip
Added GTK+2.0 engine
Ia Ora was created by Mandriva so that Qt and GTK applications could have a uniform look. It only seems fair to include the GTK style with the TDE style. Source: https://distrib-coffee.ipsl.jussieu.fr/pub/linux/Mageia/distrib/cauldron/SRPMS/core/release/ia_ora-gnome-1.0.25-12.mga9.src.rpm Licence: GNU GPL v2 or later Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'src/gtk/engine/CMakeLists.txt')
-rw-r--r--src/gtk/engine/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/gtk/engine/CMakeLists.txt b/src/gtk/engine/CMakeLists.txt
new file mode 100644
index 0000000..cbc3625
--- /dev/null
+++ b/src/gtk/engine/CMakeLists.txt
@@ -0,0 +1,21 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${GTK_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${GTK_LIBDIR}
+)
+
+tde_add_library(ia_ora SHARED
+ SOURCES
+ ia_ora_theme_draw.c
+ ia_ora_theme_main.c
+ ia_ora_rc_style.c
+
+ LINK ${GTK_LIBRARIES}
+
+ DESTINATION ${INSTALL_PATH_GTK_ENGINES}
+) \ No newline at end of file