summaryrefslogtreecommitdiffstats
path: root/style/config/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-03-19 19:07:39 +0100
committerSlávek Banko <[email protected]>2019-03-31 16:33:17 +0200
commit26ee115d569391bac2c6e2b4772ccb3de012ecdd (patch)
tree8ea94c51288a1f967d1ef5b02ae114edfeb71e78 /style/config/CMakeLists.txt
parentb850117f2d199a02a9ae498d2ffaa23742f9c2a7 (diff)
downloadtde-style-lipstik-26ee115d569391bac2c6e2b4772ccb3de012ecdd.tar.gz
tde-style-lipstik-26ee115d569391bac2c6e2b4772ccb3de012ecdd.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit e7c75e712197761e6b8ac4ab59b88ef9a1896eae)
Diffstat (limited to 'style/config/CMakeLists.txt')
-rw-r--r--style/config/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/style/config/CMakeLists.txt b/style/config/CMakeLists.txt
new file mode 100644
index 0000000..98a0d76
--- /dev/null
+++ b/style/config/CMakeLists.txt
@@ -0,0 +1,26 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+
+##### tdestyle_lipstik_config (kpart)
+
+tde_add_kpart( tdestyle_lipstik_config AUTOMOC
+
+ SOURCES
+ lipstikconf.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)