summaryrefslogtreecommitdiffstats
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
new file mode 100644
index 0000000..6692d6d
--- /dev/null
+++ b/client/CMakeLists.txt
@@ -0,0 +1,42 @@
+################################################################################
+# Polyester - widget style and twin decoration aimed to be a good balance #
+# between eye candy and simplicity #
+# #
+# This file is released under the GNU GPL version 3 or later. #
+# Improvements and feedback are welcome! #
+################################################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+tde_import(twin)
+
+### twin_polyester (kpart) #####################################################
+tde_add_kpart(twin_polyester
+ AUTOMOC
+
+ SOURCES
+ polyester.cc
+ shadow.cpp
+ ${CMAKE_SOURCE_DIR}/style/misc.cpp
+
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdecorations-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+### configuration module #######################################################
+add_subdirectory(config) \ No newline at end of file