summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-12-31 12:15:57 +0100
committerSlávek Banko <[email protected]>2021-12-31 12:21:45 +0100
commit5363fd55b8fed6a22d63017ff110ddd7dc619c1a (patch)
tree800c4cdcf14dc062f6a0d70746d04fcf508bc16e /CMakeLists.txt
parentaf0617f88ea621a3cd8de1c9814f53da4afbefaa (diff)
downloadtdeaddons-5363fd55b8fed6a22d63017ff110ddd7dc619c1a.tar.gz
tdeaddons-5363fd55b8fed6a22d63017ff110ddd7dc619c1a.zip
Add option WITH_GCC_VISIBILITY.
Fix building with hidden visibility. Add missing definitions to config.h.cmake. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 762bfec2c849854fc0247acf8d2f107c27b17940)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0353ce8..6ce10c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,12 +41,13 @@ tde_setup_paths( )
##### optional stuff ############################
-option( WITH_ALL_OPTIONS "Enable all sane optional stuff" OFF )
-option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
-option( WITH_SDL "Enable SDL support" ${WITH_ALL_OPTIONS} )
-option( WITH_BERKELEY_DB "Enable Berkeley DB support" ${WITH_ALL_OPTIONS} )
-option( WITH_XMMS "Enable xmms support" OFF )
-option( WITH_TEST "Build tests" OFF )
+option( WITH_ALL_OPTIONS "Enable all sane optional stuff" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
+option( WITH_SDL "Enable SDL support" ${WITH_ALL_OPTIONS} )
+option( WITH_BERKELEY_DB "Enable Berkeley DB support" ${WITH_ALL_OPTIONS} )
+option( WITH_XMMS "Enable xmms support" OFF )
+option( WITH_TEST "Build tests" OFF )
##### options comments ##########################