summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/lnk/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-15 20:12:47 +0200
committerSlávek Banko <[email protected]>2020-07-16 14:56:12 +0200
commite604ddcc4c22f4baa33b3ac7737271346c5b33c8 (patch)
tree5801d6f9c361d087b54fff6d554d02c91befcb57 /tdefile-plugins/lnk/CMakeLists.txt
parent02e3da597ed8db74f0a8e8866682d4549da9fbd0 (diff)
downloadtdeaddons-e604ddcc4c22f4baa33b3ac7737271346c5b33c8.tar.gz
tdeaddons-e604ddcc4c22f4baa33b3ac7737271346c5b33c8.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit cb8cda7bca532df21c02bc4d2bfd03387df7f852)
Diffstat (limited to 'tdefile-plugins/lnk/CMakeLists.txt')
-rw-r--r--tdefile-plugins/lnk/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/tdefile-plugins/lnk/CMakeLists.txt b/tdefile-plugins/lnk/CMakeLists.txt
index 3636de5..d6a332f 100644
--- a/tdefile-plugins/lnk/CMakeLists.txt
+++ b/tdefile-plugins/lnk/CMakeLists.txt
@@ -33,14 +33,20 @@ tde_add_kpart( tdefile_lnk AUTOMOC
##### other data ################################
-install( FILES lnkforward.desktop
+tde_create_translated_desktop(
+ SOURCE lnkforward.desktop
DESTINATION ${APPS_INSTALL_DIR}/.hidden
+ PO_DIR tdefile-desktops
)
-install( FILES x-win-lnk.desktop
+tde_create_translated_desktop(
+ SOURCE x-win-lnk.desktop
DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR tdefile-desktops
)
-install( FILES tdefile_lnk.desktop
+tde_create_translated_desktop(
+ SOURCE tdefile_lnk.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdefile-desktops
)