summaryrefslogtreecommitdiffstats
path: root/kcontrol/kthememanager/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-26 11:36:35 +0200
committerSlávek Banko <[email protected]>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /kcontrol/kthememanager/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kcontrol/kthememanager/CMakeLists.txt')
-rw-r--r--kcontrol/kthememanager/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/kcontrol/kthememanager/CMakeLists.txt b/kcontrol/kthememanager/CMakeLists.txt
index b3d000aa5..f55ea2de8 100644
--- a/kcontrol/kthememanager/CMakeLists.txt
+++ b/kcontrol/kthememanager/CMakeLists.txt
@@ -22,8 +22,17 @@ link_directories(
##### other data ################################
-install( FILES kthememanager.desktop installktheme.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES x-ktheme.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
+tde_create_translated_desktop(
+ SOURCE kthememanager.desktop installktheme.desktop
+ PO_DIR kcontrol-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE x-ktheme.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+ PO_DIR kcontrol-desktops
+)
+
install( PROGRAMS kdeinstallktheme DESTINATION ${BIN_INSTALL_DIR} )