summaryrefslogtreecommitdiffstats
path: root/ksplashml/themeengine/redmond/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-02-01 01:10:54 +0100
committerSlávek Banko <[email protected]>2021-02-01 01:11:09 +0100
commit49171c17078464b11cb99be025a28856c225429b (patch)
tree14cbc28947858a2b80baa2ee0789f431557570d6 /ksplashml/themeengine/redmond/CMakeLists.txt
parentf065e018dbbc70722bee1d8d4020867ba7251f0b (diff)
downloadtdebase-49171c17078464b11cb99be025a28856c225429b.tar.gz
tdebase-49171c17078464b11cb99be025a28856c225429b.zip
Update CMake rules for merging translations into Standard and Redmond ksplash themes.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 4d1cd4d95deed07ea48842b618fc4de61f6694ee)
Diffstat (limited to 'ksplashml/themeengine/redmond/CMakeLists.txt')
-rw-r--r--ksplashml/themeengine/redmond/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/ksplashml/themeengine/redmond/CMakeLists.txt b/ksplashml/themeengine/redmond/CMakeLists.txt
index 52bc35732..7284c40be 100644
--- a/ksplashml/themeengine/redmond/CMakeLists.txt
+++ b/ksplashml/themeengine/redmond/CMakeLists.txt
@@ -25,7 +25,12 @@ link_directories(
##### other data ################################
-install( FILES Theme.rc DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/Redmond )
+tde_create_translated_desktop(
+ SOURCE Theme.rc
+ DESTINATION ${DATA_INSTALL_DIR}/ksplash/Themes/Redmond
+ PO_DIR ksplash-themes
+)
+
tde_create_translated_desktop(
SOURCE ksplashredmond.desktop
DESTINATION ${SERVICES_INSTALL_DIR}