summaryrefslogtreecommitdiffstats
path: root/tdm/backend/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2024-04-15 02:56:07 +0200
committerSlávek Banko <[email protected]>2024-04-15 02:56:07 +0200
commit28a2ef7c5f28dea8ce9b5d2f14b366ada0353e0c (patch)
treedd79f52f56c53af93fd97eecd7c06589c02796f3 /tdm/backend/CMakeLists.txt
parentd5083f71dbc8dd315f1a919e475ef9a47eb60fb2 (diff)
downloadtdebase-28a2ef7c5f28dea8ce9b5d2f14b366ada0353e0c.tar.gz
tdebase-28a2ef7c5f28dea8ce9b5d2f14b366ada0353e0c.zip
tdm: Allow to detect pthread_setname_np. Add linking pthread.
This relates to issue #473. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'tdm/backend/CMakeLists.txt')
-rw-r--r--tdm/backend/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tdm/backend/CMakeLists.txt b/tdm/backend/CMakeLists.txt
index f09704486..cb0cd3d3f 100644
--- a/tdm/backend/CMakeLists.txt
+++ b/tdm/backend/CMakeLists.txt
@@ -49,6 +49,6 @@ tde_add_executable( tdm
process.c protodpy.c reset.c resource.c rpcauth.c
server.c session.c sessreg.c socket.c streams.c
util.c xdmauth.c xdmcp.c
- LINK X11 ${XAU_LIBRARIES} ${DBUS_LIBRARIES} ${CRYPT_LIBRARY} ${PAM_LIBRARY} ${UTIL_LIBRARY} ${XDMCP_LIBRARIES}
+ LINK X11 pthread ${XAU_LIBRARIES} ${DBUS_LIBRARIES} ${CRYPT_LIBRARY} ${PAM_LIBRARY} ${UTIL_LIBRARY} ${XDMCP_LIBRARIES}
DESTINATION ${BIN_INSTALL_DIR}
)