summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2023-01-25 13:41:09 +0900
committerMichele Calgaro <[email protected]>2023-01-25 13:41:09 +0900
commitb8225d27fca0564fda7f39b37d0e84b2654d2e49 (patch)
tree08b34df00db68a4bb60373f0fdf5c4f8ecaa0d36 /debian
parente274309d9293777aaaecebccaa29a339a05bd4f9 (diff)
downloadtdebluez-b8225d27fca0564fda7f39b37d0e84b2654d2e49.tar.gz
tdebluez-b8225d27fca0564fda7f39b37d0e84b2654d2e49.zip
Updated cmake related code to TDE standard.
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/libtdebluez.install2
-rwxr-xr-xdebian/rules2
3 files changed, 3 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index ef9da49..d8364d7 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: tde
Priority: optional
Maintainer: Debian TDE Team <[email protected]>
Uploaders: ...
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake-trinity, ninja-build, tdelibs14-trinity-dev, libdbus-1-tqt-dev, libdbus-1-3 (>= 1.10.26)
+Build-Depends: cdbs, debhelper (>= 9~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev, libdbus-1-tqt-dev, libdbus-1-3 (>= 1.10.26)
Standards-Version: 3.8.0
#Vcs-Svn: svn://svn.debian.org/pkg-kde/kde-extras/kdebluetooth/trunk/
#Vcs-Browser: http://svn.debian.org/wsvn/pkg-kde/kde-extras/kdebluetooth/trunk/
diff --git a/debian/libtdebluez.install b/debian/libtdebluez.install
index cba8c73..ef8dc81 100644
--- a/debian/libtdebluez.install
+++ b/debian/libtdebluez.install
@@ -2,4 +2,4 @@ opt/trinity/lib/libtdebluez.so.0
opt/trinity/lib/libtdebluez.so.0.0.1
opt/trinity/lib/libtdebluez.so
opt/trinity/lib/libtdebluez.la
-etc/trinity/dbus-1/system.d/org.trinitydesktop.tdebluez.conf /etc/dbus-1/system.d/
+/etc/dbus-1/system.d/org.trinitydesktop.tdebluez.conf
diff --git a/debian/rules b/debian/rules
index a6797f1..5a0da42 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
-DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
-DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_VERBOSE_MAKEFILE="ON" \