summaryrefslogtreecommitdiffstats
path: root/src/tdebluez-common/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanoil Kotsev <[email protected]>2018-11-12 21:18:37 +0100
committerEmanoil Kotsev <[email protected]>2023-01-14 03:44:08 +0000
commite274309d9293777aaaecebccaa29a339a05bd4f9 (patch)
treea00349c31b90cdedaa6e351dfe93950b55903dce /src/tdebluez-common/CMakeLists.txt
parent63c233987977aa48b701edeb47079a6153359fbe (diff)
downloadtdebluez-e274309d9293777aaaecebccaa29a339a05bd4f9.tar.gz
tdebluez-e274309d9293777aaaecebccaa29a339a05bd4f9.zip
Based on KDE3 bluez4 version a TDE bluez5 version was created
Signed-off-by: Emanoil Kotsev <[email protected]>
Diffstat (limited to 'src/tdebluez-common/CMakeLists.txt')
-rw-r--r--src/tdebluez-common/CMakeLists.txt67
1 files changed, 67 insertions, 0 deletions
diff --git a/src/tdebluez-common/CMakeLists.txt b/src/tdebluez-common/CMakeLists.txt
new file mode 100644
index 0000000..8dbf649
--- /dev/null
+++ b/src/tdebluez-common/CMakeLists.txt
@@ -0,0 +1,67 @@
+#################################################
+#
+# (C) 2018 Emanoil Kotsev
+# deloptes (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+project( tdebluez-common )
+
+# include( ConfigureChecks.cmake )
+
+# import required
+#tde_import( lib... )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/tdebluez-common
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+#link_directories(
+# ${TQT_LIBRARY_DIRS}
+#)
+
+
+##### other data ################################
+# Example
+#install( FILES knotes.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+#install( FILES knoteconfig.kcfg knotesglobalconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
+#install( FILES knotesappui.rc knotesui.rc DESTINATION ${DATA_INSTALL_DIR}/knotes )
+#install( FILES local.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes )
+#install( FILES knotes_manager.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources )
+
+# # from tdebase/applnk/Makefile.am
+# install-data-local:
+# $(mkinstalldirs) $(DESTDIR)$(kde_appsdir)/Settings/Network/Bluetooth
+# $(INSTALL_DATA) $(srcdir)/kde-settings-network-bluetooth.directory \
+# $(DESTDIR)$(kde_appsdir)/Settings/Network/Bluetooth/.directory
+#
+# uninstall-local:
+# -rm -f $(DESTDIR)$(kde_appsdir)/Settings/Network/Bluetooth/.directory
+
+##### install import cmake modules ###############
+#tde_install_export( )
+
+# Bluetooth directory entry in the control center
+install( FILES tde-settings-network-bluetooth.directory
+ DESTINATION ${DATA_INSTALL_DIR}/tdebluez )
+
+# Bluetooth access to system debus org.bluez
+install( FILES org.trinitydesktop.tdebluez.conf
+ DESTINATION ${DBUS_SYS_DIR} )
+# DESTINATION ${DBUS_SYSTEM_CONF_DIRECTORY} )
+
+
+
+add_subdirectory( icons )
+add_subdirectory( mimetypes )
+#add_subdirectory( dunhandler )
+#add_subdirectory( faxhandler ) \ No newline at end of file