summaryrefslogtreecommitdiffstats
path: root/src/tdeioslave/obex/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanoil Kotsev <[email protected]>2018-11-12 21:18:37 +0100
committerEmanoil Kotsev <[email protected]>2023-01-14 03:44:08 +0000
commite274309d9293777aaaecebccaa29a339a05bd4f9 (patch)
treea00349c31b90cdedaa6e351dfe93950b55903dce /src/tdeioslave/obex/CMakeLists.txt
parent63c233987977aa48b701edeb47079a6153359fbe (diff)
downloadtdebluez-e274309d9293777aaaecebccaa29a339a05bd4f9.tar.gz
tdebluez-e274309d9293777aaaecebccaa29a339a05bd4f9.zip
Based on KDE3 bluez4 version a TDE bluez5 version was created
Signed-off-by: Emanoil Kotsev <[email protected]>
Diffstat (limited to 'src/tdeioslave/obex/CMakeLists.txt')
-rw-r--r--src/tdeioslave/obex/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/tdeioslave/obex/CMakeLists.txt b/src/tdeioslave/obex/CMakeLists.txt
new file mode 100644
index 0000000..d31aa6f
--- /dev/null
+++ b/src/tdeioslave/obex/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2018 Emanoil Kotsev
+# deloptes (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/src/libtdeobex
+ ${CMAKE_BINARY_DIR}/src/libtdeobex
+ ${CMAKE_SOURCE_DIR}/src/tdeioslave/obex
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${DBUS_INCLUDE_DIRS}
+ ${DBUS_TQT_INCLUDE_DIRS}
+)
+##### tdeio_bluetooth (static) #############################
+set( target tdeio_obex )
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES tdeio_obex.cpp obex.cpp
+ LINK ${DBUS_TQT_LIBRARIES} tdeio-shared tdeobex-shared obexinterfaces-static
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+install( FILES obexftp.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES obexopp.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+install( FILES obex_sidebarentry.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqsidebartng/virtual_folders/services ) \ No newline at end of file