summaryrefslogtreecommitdiffstats
path: root/src/tdebluez-common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tdebluez-common/CMakeLists.txt')
-rw-r--r--src/tdebluez-common/CMakeLists.txt62
1 files changed, 13 insertions, 49 deletions
diff --git a/src/tdebluez-common/CMakeLists.txt b/src/tdebluez-common/CMakeLists.txt
index 8dbf649..ac577e9 100644
--- a/src/tdebluez-common/CMakeLists.txt
+++ b/src/tdebluez-common/CMakeLists.txt
@@ -9,59 +9,23 @@
#
#################################################
-project( tdebluez-common )
-# include( ConfigureChecks.cmake )
-
-# import required
-#tde_import( lib... )
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}
- ${CMAKE_SOURCE_DIR}/tdebluez-common
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-#link_directories(
-# ${TQT_LIBRARY_DIRS}
-#)
+add_subdirectory( icons )
+add_subdirectory( mimetypes )
+#add_subdirectory( dunhandler )
+#add_subdirectory( faxhandler )
##### other data ################################
-# Example
-#install( FILES knotes.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-#install( FILES knoteconfig.kcfg knotesglobalconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
-#install( FILES knotesappui.rc knotesui.rc DESTINATION ${DATA_INSTALL_DIR}/knotes )
-#install( FILES local.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes )
-#install( FILES knotes_manager.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tderesources )
-
-# # from tdebase/applnk/Makefile.am
-# install-data-local:
-# $(mkinstalldirs) $(DESTDIR)$(kde_appsdir)/Settings/Network/Bluetooth
-# $(INSTALL_DATA) $(srcdir)/kde-settings-network-bluetooth.directory \
-# $(DESTDIR)$(kde_appsdir)/Settings/Network/Bluetooth/.directory
-#
-# uninstall-local:
-# -rm -f $(DESTDIR)$(kde_appsdir)/Settings/Network/Bluetooth/.directory
-
-##### install import cmake modules ###############
-#tde_install_export( )
# Bluetooth directory entry in the control center
-install( FILES tde-settings-network-bluetooth.directory
- DESTINATION ${DATA_INSTALL_DIR}/tdebluez )
-
-# Bluetooth access to system debus org.bluez
-install( FILES org.trinitydesktop.tdebluez.conf
- DESTINATION ${DBUS_SYS_DIR} )
-# DESTINATION ${DBUS_SYSTEM_CONF_DIRECTORY} )
-
-
+tde_create_translated_desktop(
+ SOURCE tde-settings-network-bluetooth.directory
+ DESTINATION ${DATA_INSTALL_DIR}/tdebluez
+)
-add_subdirectory( icons )
-add_subdirectory( mimetypes )
-#add_subdirectory( dunhandler )
-#add_subdirectory( faxhandler ) \ No newline at end of file
+# Bluetooth access to system debus org.bluez
+install(
+ FILES org.trinitydesktop.tdebluez.conf
+ DESTINATION ${DBUS_SYS_DIR}
+)