summaryrefslogtreecommitdiffstats
path: root/ktouch/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-06-27 16:35:25 +0200
committerSlávek Banko <[email protected]>2019-06-28 13:45:47 +0200
commitaca01d5a8b7d3de53fa34696e18c91db720a5ab6 (patch)
tree6b9b83c599cc5db58df8041ca5cf812e00bbd25e /ktouch/src/CMakeLists.txt
parent88af19c041ad4f1139f6f0a35cd1a4fe2018425f (diff)
downloadtdeedu-aca01d5a8b7d3de53fa34696e18c91db720a5ab6.tar.gz
tdeedu-aca01d5a8b7d3de53fa34696e18c91db720a5ab6.zip
Conversion to the cmake building system.
Add includes to UI files to resolve FTBFS. Signed-off-by: gregory guy <[email protected]> Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit d4a1613e9f119ae68c695ab60f8d9856d1a54a52)
Diffstat (limited to 'ktouch/src/CMakeLists.txt')
-rw-r--r--ktouch/src/CMakeLists.txt71
1 files changed, 71 insertions, 0 deletions
diff --git a/ktouch/src/CMakeLists.txt b/ktouch/src/CMakeLists.txt
new file mode 100644
index 00000000..26dacfc2
--- /dev/null
+++ b/ktouch/src/CMakeLists.txt
@@ -0,0 +1,71 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### ktouch (executable)
+
+tde_add_executable( ktouch AUTOMOC
+
+ SOURCES
+ ktouchcoloreditor_dlg.ui
+ ktouchlectureeditor_dlg.ui
+ ktouchopenrequest_dlg.ui
+ ktouchprefcolorslayout.ui
+ ktouchprefgenerallayout.ui
+ ktouchprefkeyboardlayout.ui
+ ktouchpreftraininglayout.ui
+ ktouchstatistics_dlg.ui
+ ktouchstatuslayout.ui
+ prefs.kcfgc
+ ktouchchartwidget.cpp
+ ktouchcolorscheme.cpp
+ ktouch.cpp
+ ktouchdefaults.cpp
+ ktouchkeyboardwidget.cpp
+ ktouchkeyconnector.cpp
+ ktouchkey.cpp
+ ktouchkeys.cpp
+ ktouchlecture.cpp
+ ktouchlectureeditor.cpp
+ ktouchleveldata.cpp
+ ktouchopenrequest.cpp
+ ktouchslideline.cpp
+ ktouchstatistics.cpp
+ ktouchstatisticsdata.cpp
+ ktouchstatus.cpp
+ ktouchtrainer.cpp
+ ktouchutils.cpp
+ main.cpp
+ ktouchcoloreditor.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ tdeeduplot-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES ktouchui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/ktouch
+)
+
+install(
+ FILES ktouch.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)