summaryrefslogtreecommitdiffstats
path: root/kenolaba/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <[email protected]>2016-02-25 06:23:55 +0300
committerSlávek Banko <[email protected]>2016-03-14 23:04:06 +0100
commitc70db62d3671e524d23ac974d296eb218159b000 (patch)
tree08d8ed5d0c7c170a7940bcbb80989b99ead98447 /kenolaba/CMakeLists.txt
parent133cc7035dbdcaf812d8370f729530fa60547f92 (diff)
downloadtdegames-c70db62d3671e524d23ac974d296eb218159b000.tar.gz
tdegames-c70db62d3671e524d23ac974d296eb218159b000.zip
Initial cmake conversion
Diffstat (limited to 'kenolaba/CMakeLists.txt')
-rw-r--r--kenolaba/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kenolaba/CMakeLists.txt b/kenolaba/CMakeLists.txt
new file mode 100644
index 00000000..e5398246
--- /dev/null
+++ b/kenolaba/CMakeLists.txt
@@ -0,0 +1,42 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( toolbar )
+add_subdirectory( bitmaps )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kenolaba (executable) #####################
+
+tde_add_executable( kenolaba AUTOMOC
+ SOURCES Board.cpp Move.cpp BoardWidget.cpp AbTop.cpp kenolaba.cpp Spy.cpp
+ Ball.cpp Network.cpp EvalDlg.ui EvalDlgImpl.cpp EvalScheme.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kenolaba )
+
+
+##### other data ################################
+install( FILES kenolabaui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kenolaba
+)
+
+install( FILES kenolaba.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)