summaryrefslogtreecommitdiffstats
path: root/katomic/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'katomic/CMakeLists.txt')
-rw-r--r--katomic/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/katomic/CMakeLists.txt b/katomic/CMakeLists.txt
new file mode 100644
index 00000000..61988b67
--- /dev/null
+++ b/katomic/CMakeLists.txt
@@ -0,0 +1,57 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/libtdegames/highscore
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### katomic (executable) ######################
+
+tde_add_executable( katomic AUTOMOC
+ SOURCES feld.cpp molek.cpp main.cpp toplevel.cpp configbox.cpp gamewidget.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( katomic )
+
+
+##### other data ################################
+
+install( DIRECTORY levels
+ DESTINATION ${DATA_INSTALL_DIR}/katomic
+)
+
+install( FILES abilder.png molek.png
+ DESTINATION ${DATA_INSTALL_DIR}/katomic/pics
+)
+
+install( FILES katomicui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/katomic
+)
+
+install( FILES katomic.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)