summaryrefslogtreecommitdiffstats
path: root/kmahjongg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kmahjongg/CMakeLists.txt')
-rw-r--r--kmahjongg/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/kmahjongg/CMakeLists.txt b/kmahjongg/CMakeLists.txt
new file mode 100644
index 00000000..c90d3fc8
--- /dev/null
+++ b/kmahjongg/CMakeLists.txt
@@ -0,0 +1,47 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kmahjongg (executable) ####################
+
+tde_add_executable( kmahjongg AUTOMOC
+ SOURCES main.cpp kmahjongg.cpp boardwidget.cpp Tileset.cpp BoardLayout.cpp
+ GameTimer.cpp Background.cpp Preview.cpp prefs.kcfgc Editor.cpp
+ HighScore.cpp settings.ui
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kmahjongg )
+
+
+##### other data ################################
+
+install( FILES kmahjonggui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kmahjongg
+)
+
+install( FILES kmahjongg.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kmahjongg.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)