summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-29 15:09:53 +0200
committerSlávek Banko <[email protected]>2021-07-29 15:09:53 +0200
commitb21b72577a8b227d8980f9ed9611601861ef4bb3 (patch)
treeed5aca36ef06968819526a11aab4576db4216af1 /translations/messages/CMakeLists.txt
parentb9dd4dd6819f1fbfedf1b014a9f04d84d284986a (diff)
downloadtdeio-apt-b21b72577a8b227d8980f9ed9611601861ef4bb3.tar.gz
tdeio-apt-b21b72577a8b227d8980f9ed9611601861ef4bb3.zip
Use common rules for build and install translations.
Change documentation path to tdeioslave/apt. Change CMake project name to tdeio_apt. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/translations/messages/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )