summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt22
1 files changed, 14 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 95624d8..7d9cf9e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -37,17 +37,23 @@ tde_add_kpart( tdeio_apt MODULE AUTOMOC
##### other data
-install(
- FILES apt.protocol apt+http.protocol
+foreach( _protocol apt.protocol apt+http.protocol )
+ tde_create_translated_desktop(
+ SOURCE ${_protocol}
DESTINATION ${SERVICES_INSTALL_DIR}
-)
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
+ )
+endforeach( )
+
+foreach( _desktop apt-file.desktop apt-files.desktop apt-search.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${SERVICES_INSTALL_DIR}/searchproviders
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files
+ )
+endforeach( )
install(
FILES tdeio_apt.css tdedeb_logo.png
DESTINATION ${DATA_INSTALL_DIR}/tdeio_apt/
)
-
-install(
- FILES apt-search.desktop apt-file.desktop apt-files.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/searchproviders
-)