summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2018-09-11 16:23:19 +0200
committergregory guy <[email protected]>2018-09-11 16:23:19 +0200
commit6e5f56beeb4b71f36cc2f50c8d38355d3915db87 (patch)
treefbcf258131f96641aa041587a3bbe19eaf551df2 /CMakeLists.txt
parent03fbabea65f95651d5028e06e956c691bae338af (diff)
downloadtdeio-ftps-6e5f56beeb4b71f36cc2f50c8d38355d3915db87.tar.gz
tdeio-ftps-6e5f56beeb4b71f36cc2f50c8d38355d3915db87.zip
cmake conversion
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..e7691d8
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,66 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+cmake_minimum_required( VERSION 2.8 )
+
+
+#### general package setup
+
+project( tdeio-ftps )
+set( VERSION R14.1.0 )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
+
+
+#### include our cmake modules
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" OFF )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( tdeio_ftps )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )