summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2018-09-12 17:34:22 +0200
committerSlávek Banko <[email protected]>2018-09-13 14:19:36 +0200
commit78d28ba143b86f048271e47a459586f5e20e7356 (patch)
tree2daea67f3b7bb37d9a9ca3f5d9ca2dfbd4fd0194 /src/CMakeLists.txt
parent38cb1a7f70ffef70aacfc4c8879f20f3e40f6745 (diff)
downloadtdeio-umountwrapper-78d28ba143b86f048271e47a459586f5e20e7356.tar.gz
tdeio-umountwrapper-78d28ba143b86f048271e47a459586f5e20e7356.zip
cmake conversion
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 2cbe89d0509e2782268414c2df4a1b287d7ed6fb)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..f208f90
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeio_umountwrapper (executable)
+
+tde_add_executable( tdeio_umountwrapper AUTOMOC
+
+ SOURCES
+ main.cpp
+ tdeio_umountwrapper.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)