summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <[email protected]>2020-08-19 16:51:24 +0900
committerSlávek Banko <[email protected]>2020-09-27 19:26:17 +0200
commit49d24215b1e2557e6d0687bf4f90e6b04a0e33cb (patch)
treeb9ed8909b72683b57b1a612a826421da5c91cb7d /CMakeLists.txt
parent6736088603213890fba2c83b0c926db821d31b6e (diff)
downloadtdelibs-49d24215b1e2557e6d0687bf4f90e6b04a0e33cb.tar.gz
tdelibs-49d24215b1e2557e6d0687bf4f90e6b04a0e33cb.zip
Add an ability to specify default spell checker
There is no reason to determine it with operating system basis. Change to use build configuration instead. "ispell" by default, and you can override it. Signed-off-by: OBATA Akio <[email protected]> (cherry picked from commit 70d26004f065c5fd18be00cab17fc93ed231d849) Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a295520c..0d17d4f01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1176,6 +1176,10 @@ if( WITH_HSPELL )
endif( WITH_HSPELL )
+####" default spell checker #####################
+set( DEFAULT_SPELL_CHECKER "ISPELL" CACHE STRING "default spell checker" )
+
+
##### enable TDEIconLoader debugging ############
if ( WITH_TDEICONLOADER_DEBUG )