summaryrefslogtreecommitdiffstats
path: root/interfaces/tdescript/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-07 18:25:52 +0200
committerSlávek Banko <[email protected]>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /interfaces/tdescript/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'interfaces/tdescript/CMakeLists.txt')
-rw-r--r--interfaces/tdescript/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/interfaces/tdescript/CMakeLists.txt b/interfaces/tdescript/CMakeLists.txt
index 6b57cdeb9..276c6fb94 100644
--- a/interfaces/tdescript/CMakeLists.txt
+++ b/interfaces/tdescript/CMakeLists.txt
@@ -37,7 +37,11 @@ install( FILES
##### other data ################################
-install( FILES scriptinterface.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE scriptinterface.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/interfaces-desktops
+)
##### tdescript ###################################