summaryrefslogtreecommitdiffstats
path: root/kimgio/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Kent Hajnal <[email protected]>2024-05-17 18:16:23 -0400
committerSlávek Banko <[email protected]>2024-05-21 16:51:54 +0200
commit347a546d9dfb3210bcf907c3c622d6843d2ae9ce (patch)
treec20e7ab075804a350305442a105d848fc2232478 /kimgio/CMakeLists.txt
parent7d228ae9aae48bda07d995f3c84debadbc2c5c95 (diff)
downloadtdelibs-347a546d9dfb3210bcf907c3c622d6843d2ae9ce.tar.gz
tdelibs-347a546d9dfb3210bcf907c3c622d6843d2ae9ce.zip
Adds WebP read support to kimgio
Signed-off-by: Alex Kent Hajnal <[email protected]>
Diffstat (limited to 'kimgio/CMakeLists.txt')
-rw-r--r--kimgio/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/kimgio/CMakeLists.txt b/kimgio/CMakeLists.txt
index be10cf809..325f136f1 100644
--- a/kimgio/CMakeLists.txt
+++ b/kimgio/CMakeLists.txt
@@ -167,6 +167,19 @@ tde_add_kpart( ${target}
)
+##### kimg_webp #################################
+
+if( HAVE_WEBP )
+ set( target kimg_webp )
+ tde_add_kpart( ${target}
+ SOURCES webp.cpp
+ LINK tdecore-shared ${WEBP_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+ )
+ install( FILES webp.kimgio DESTINATION ${SERVICES_INSTALL_DIR} )
+endif( HAVE_WEBP )
+
+
##### other data ################################
install( FILES