summaryrefslogtreecommitdiffstats
path: root/tdeio/misc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-25 13:36:35 +0200
committerSlávek Banko <[email protected]>2020-06-25 13:38:09 +0200
commit3e4279ead3d02c6183681a1bad4c9cd678a5b274 (patch)
treeee00ee8ed0beb2dd1c9431f75979cd208d6ee5b2 /tdeio/misc/CMakeLists.txt
parent6e58b61177b415df6e5dd2508074d2f5722a9b9a (diff)
downloadtdelibs-3e4279ead3d02c6183681a1bad4c9cd678a5b274.tar.gz
tdelibs-3e4279ead3d02c6183681a1bad4c9cd678a5b274.zip
Simplify CMake rules for desktop file translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 42f3a62161d1b0c7047d1edfdcb8af72b7314f1b)
Diffstat (limited to 'tdeio/misc/CMakeLists.txt')
-rw-r--r--tdeio/misc/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/tdeio/misc/CMakeLists.txt b/tdeio/misc/CMakeLists.txt
index 0b75b5103..ad25c8e0d 100644
--- a/tdeio/misc/CMakeLists.txt
+++ b/tdeio/misc/CMakeLists.txt
@@ -46,18 +46,15 @@ install( FILES uiserver.h DESTINATION ${INCLUDE_INSTALL_DIR}/tdeio )
##### other data ################################
-foreach( _service
+tde_create_translated_desktop(
+ SOURCE
tdeio_uiserver.desktop tdemailservice.protocol
telnet.protocol rlogin.protocol rtsp.protocol
ssh.protocol mms.protocol mmst.protocol mmsu.protocol
pnm.protocol rtspt.protocol rtspu.protocol
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR tdeio-desktops
)
- tde_create_translated_desktop(
- SOURCE ${_service}
- DESTINATION ${SERVICES_INSTALL_DIR}
- PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeio-desktops
- )
-endforeach()
install( FILES fileshareset DESTINATION ${BIN_INSTALL_DIR}
PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_EXECUTE WORLD_EXECUTE SETUID )