summaryrefslogtreecommitdiffstats
path: root/tdeio/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-12-06 10:50:13 +0100
committerSlávek Banko <[email protected]>2020-12-06 10:50:47 +0100
commit8bc0bc7fc67437fbf757283604104e998ad2fda7 (patch)
tree49f743699c44a1613ba92435087cb4ab2ee4d80c /tdeio/tests/CMakeLists.txt
parent3a4e7a0733ee08ca552a4941c45eaaf68fad13b1 (diff)
downloadtdelibs-8bc0bc7fc67437fbf757283604104e998ad2fda7.tar.gz
tdelibs-8bc0bc7fc67437fbf757283604104e998ad2fda7.zip
tests: Wait for the dcop server to be ready.
Use a separate ICEAUTHORITY for tests. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 19f44e5ff3756172540e768fc0d08d761f0c374e)
Diffstat (limited to 'tdeio/tests/CMakeLists.txt')
-rw-r--r--tdeio/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tdeio/tests/CMakeLists.txt b/tdeio/tests/CMakeLists.txt
index 323a7d86e..e9f5ea5ff 100644
--- a/tdeio/tests/CMakeLists.txt
+++ b/tdeio/tests/CMakeLists.txt
@@ -80,6 +80,7 @@ configure_file( kmimetypetest.sh.cmake kmimetypetest.sh @ONLY )
add_test( NAME "tdeio/kmimetypetest"
COMMAND sh -x "${CMAKE_CURRENT_BINARY_DIR}/kmimetypetest.sh"
WORKING_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}" )
+set_tests_properties( "tdeio/kmimetypetest" PROPERTIES TIMEOUT 30)
# TODO add kdirwatchunittest