summaryrefslogtreecommitdiffstats
path: root/tdeioslave/http/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-07 18:25:52 +0200
committerSlávek Banko <[email protected]>2020-06-07 18:48:13 +0200
commit9756408b0ebb206b53abd2597926d8fead731977 (patch)
tree62caa2c2ebd6ebccc5472fdc7469fe54dad8b24f /tdeioslave/http/CMakeLists.txt
parentc95c7a29338aa309fab071b5a4475400fdce97a8 (diff)
downloadtdelibs-9756408b0ebb206b53abd2597926d8fead731977.tar.gz
tdelibs-9756408b0ebb206b53abd2597926d8fead731977.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 4b7a4e17362206fd2eade35ba947a850263b0ea1)
Diffstat (limited to 'tdeioslave/http/CMakeLists.txt')
-rw-r--r--tdeioslave/http/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tdeioslave/http/CMakeLists.txt b/tdeioslave/http/CMakeLists.txt
index aff6d0a4e..c29782570 100644
--- a/tdeioslave/http/CMakeLists.txt
+++ b/tdeioslave/http/CMakeLists.txt
@@ -32,10 +32,16 @@ link_directories(
##### other data ################################
-install( FILES
+foreach( _desktop
http_cache_cleaner.desktop http.protocol https.protocol
webdav.protocol webdavs.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_desktop}
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeioslave-desktops
+ )
+endforeach()
##### tdeio_http_cache_cleaner ####################