summaryrefslogtreecommitdiffstats
path: root/tdeioslave/http/Makefile.am
diff options
context:
space:
mode:
authorDarrell Anderson <[email protected]>2013-03-02 15:57:34 -0600
committerDarrell Anderson <[email protected]>2013-03-02 15:57:34 -0600
commit7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f (patch)
treec76702a7f6310fbe9d437e347535422e836e94e9 /tdeioslave/http/Makefile.am
parenta2a38be7600e2a2c2b49c66902d912ca036a2c0f (diff)
parent27bbee9a5f9dcda53d8eb23863ee670ad1360e41 (diff)
downloadtdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.tar.gz
tdelibs-7c0b0c9dc9fcbe9c198925bdc7ee18ac6be49f4f.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tdelibs
Diffstat (limited to 'tdeioslave/http/Makefile.am')
-rw-r--r--tdeioslave/http/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tdeioslave/http/Makefile.am b/tdeioslave/http/Makefile.am
new file mode 100644
index 000000000..71b6d0c60
--- /dev/null
+++ b/tdeioslave/http/Makefile.am
@@ -0,0 +1,31 @@
+# $Id$
+# Makefile.am of tdebase/tdeioslave/http
+
+SUBDIRS = kcookiejar
+
+INCLUDES= -I$(top_srcdir)/interfaces -I$(top_srcdir)/tdeio/httpfilter -I$(top_srcdir)/tdecore/network $(all_includes) $(GSSAPI_INCS)
+AM_LDFLAGS = $(all_libraries) $(GSSAPI_RPATH)
+
+####### Files
+
+bin_PROGRAMS=
+lib_LTLIBRARIES=
+tdeinit_LTLIBRARIES = tdeio_http_cache_cleaner.la
+kde_module_LTLIBRARIES = tdeio_http.la
+
+tdeio_http_la_SOURCES = http.cc
+tdeio_http_la_METASOURCES = AUTO
+tdeio_http_la_LIBADD = $(LIB_KIO) $(top_builddir)/tdeio/httpfilter/libhttpfilter.la $(LIB_QT) $(LIB_TDECORE) $(LIBZ) $(top_builddir)/dcop/libDCOP.la $(top_builddir)/tdeio/misc/tdentlm/libtdentlm.la
+tdeio_http_la_LDFLAGS = $(all_libraries) $(GSSAPI_RPATH) -module $(KDE_PLUGIN) $(GSSAPI_LIBS)
+
+tdeio_http_cache_cleaner_la_SOURCES = http_cache_cleaner.cpp
+tdeio_http_cache_cleaner_la_LIBADD = $(LIB_KIO) $(LIB_QT) $(LIB_TDECORE) $(top_builddir)/dcop/libDCOP.la
+tdeio_http_cache_cleaner_la_LDFLAGS = -module -avoid-version
+
+noinst_HEADERS = http.h
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = http_cache_cleaner.desktop http.protocol https.protocol \
+ webdav.protocol webdavs.protocol
+
+include $(top_srcdir)/admin/Doxyfile.am