summaryrefslogtreecommitdiffstats
path: root/xine_artsplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-12-27 14:12:10 +0900
committerMichele Calgaro <[email protected]>2024-12-27 20:16:31 +0900
commit88cb1417b60deb6357228acb88f86f3f840bbb40 (patch)
tree03e358b506a152bb592c30cab089222a3e0fc0f1 /xine_artsplugin/CMakeLists.txt
parentdafa15cc2895d4b34f96be3f34766119a024296b (diff)
downloadtdemultimedia-88cb1417b60deb6357228acb88f86f3f840bbb40.tar.gz
tdemultimedia-88cb1417b60deb6357228acb88f86f3f840bbb40.zip
Replace pthread and dl linking with cmake-based variables
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 1bbc86f7b626b7754fba76d992b367e734991291)
Diffstat (limited to 'xine_artsplugin/CMakeLists.txt')
-rw-r--r--xine_artsplugin/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/xine_artsplugin/CMakeLists.txt b/xine_artsplugin/CMakeLists.txt
index 0b647c96..4b69798f 100644
--- a/xine_artsplugin/CMakeLists.txt
+++ b/xine_artsplugin/CMakeLists.txt
@@ -39,7 +39,7 @@ tde_add_library( arts_xine SHARED AUTOMOC
VERSION 0.0.0
LINK
mcop kmedia2_idl soundserver_idl artsflow artsflow_idl
- ${ARTS_LIBRARIES} ${XINE_LIBRARIES} ${XEXT_LIBRARIES} X11 pthread
+ ${ARTS_LIBRARIES} ${XINE_LIBRARIES} ${XEXT_LIBRARIES} X11 ${CMAKE_THREAD_LIBS_INIT}
DESTINATION ${LIB_INSTALL_DIR}
)