summaryrefslogtreecommitdiffstats
path: root/kdict/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-08 22:39:20 +0200
committerSlávek Banko <[email protected]>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /kdict/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kdict/CMakeLists.txt')
-rw-r--r--kdict/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/kdict/CMakeLists.txt b/kdict/CMakeLists.txt
index d699394b..dd9db235 100644
--- a/kdict/CMakeLists.txt
+++ b/kdict/CMakeLists.txt
@@ -29,7 +29,12 @@ link_directories(
##### other data ################################
tde_install_icons( )
-install( FILES kdict.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kdict.desktop
+ PO_DIR kdict-desktops
+)
+
install( FILES kdictui.rc DESTINATION ${DATA_INSTALL_DIR}/kdict )