summaryrefslogtreecommitdiffstats
path: root/kget/kget_plug_in/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-08 22:39:20 +0200
committerSlávek Banko <[email protected]>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /kget/kget_plug_in/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kget/kget_plug_in/CMakeLists.txt')
-rw-r--r--kget/kget_plug_in/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/kget/kget_plug_in/CMakeLists.txt b/kget/kget_plug_in/CMakeLists.txt
index bc5911d8..1084405d 100644
--- a/kget/kget_plug_in/CMakeLists.txt
+++ b/kget/kget_plug_in/CMakeLists.txt
@@ -24,9 +24,16 @@ link_directories(
tde_install_icons( )
-install( FILES
- kget_plug_in.rc kget_plug_in.desktop
- DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins )
+tde_create_translated_desktop(
+ SOURCE kget_plug_in.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+ PO_DIR kget-desktops
+)
+
+install(
+ FILES kget_plug_in.rc
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+)
##### tdehtml_kget (module) #######################