summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2018-12-31 04:37:35 +0100
committerSlávek Banko <[email protected]>2018-12-31 04:39:22 +0100
commitb5f92b0b7f57fa274ad33def7011b0b8f78e5f5e (patch)
treeaf13ee771c7cbaa02acd05c88bcdff795914c25a /CMakeLists.txt
parentd8a80ff0608f8ccfe125df0c275542e0024966a3 (diff)
downloadtdenetworkmanager-b5f92b0b7f57fa274ad33def7011b0b8f78e5f5e.tar.gz
tdenetworkmanager-b5f92b0b7f57fa274ad33def7011b0b8f78e5f5e.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 3dc2f27d3cf75b281bdfd1067b26a0b21bf3449a)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 191a59f..c1f7e42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,13 @@ endif( )
# option( WITH_LDAP "Enable LDAP support" OFF )
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )