summaryrefslogtreecommitdiffstats
path: root/kaddressbook/interfaces/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-12 16:15:10 +0200
committerSlávek Banko <[email protected]>2020-07-14 19:26:10 +0200
commit3e868d844c44aab62fd1324e52872afd1f706cd3 (patch)
treeb3c06badd9b8f004ae92024d53c8bf15b8849cf0 /kaddressbook/interfaces/CMakeLists.txt
parent9d2dbcebff2529124b4a522d3714b308548ee9ec (diff)
downloadtdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.tar.gz
tdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 0d3043b6308af148da06ac14c53defc4b1e7e138)
Diffstat (limited to 'kaddressbook/interfaces/CMakeLists.txt')
-rw-r--r--kaddressbook/interfaces/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/kaddressbook/interfaces/CMakeLists.txt b/kaddressbook/interfaces/CMakeLists.txt
index b0511b83b..97a634eee 100644
--- a/kaddressbook/interfaces/CMakeLists.txt
+++ b/kaddressbook/interfaces/CMakeLists.txt
@@ -33,10 +33,13 @@ install( FILES
##### other data ################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
kaddressbook_contacteditorwidget.desktop
kaddressbook_extension.desktop kaddressbook_xxport.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kaddressbook-desktops
+)
##### kabinterfaces (shared) ####################