summaryrefslogtreecommitdiffstats
path: root/kmobile/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-12 16:15:10 +0200
committerSlávek Banko <[email protected]>2020-07-14 19:26:10 +0200
commit3e868d844c44aab62fd1324e52872afd1f706cd3 (patch)
treeb3c06badd9b8f004ae92024d53c8bf15b8849cf0 /kmobile/CMakeLists.txt
parent9d2dbcebff2529124b4a522d3714b308548ee9ec (diff)
downloadtdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.tar.gz
tdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 0d3043b6308af148da06ac14c53defc4b1e7e138)
Diffstat (limited to 'kmobile/CMakeLists.txt')
-rw-r--r--kmobile/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/kmobile/CMakeLists.txt b/kmobile/CMakeLists.txt
index 1c5cf0c07..43cff0a60 100644
--- a/kmobile/CMakeLists.txt
+++ b/kmobile/CMakeLists.txt
@@ -31,8 +31,18 @@ link_directories(
##### other data ################################
tde_install_icons( kmobile )
-install( FILES kmobile.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES libkmobile.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kmobile.desktop
+ PO_DIR kmobile-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE libkmobile.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kmobile-desktops
+)
+
install( FILES kmobileui.rc DESTINATION ${DATA_INSTALL_DIR}/kmobile )