summaryrefslogtreecommitdiffstats
path: root/tdeioslaves/imap4/CMakeLists.txt
diff options
context:
space:
mode:
authorDarrell Anderson <[email protected]>2014-02-06 17:54:49 -0600
committerDarrell Anderson <[email protected]>2014-02-06 17:54:49 -0600
commitca705978d11b2e0bdcaf8186b0addff48d851483 (patch)
treeda2d37c0fc29b1746cc24594e948bc7c9f1241eb /tdeioslaves/imap4/CMakeLists.txt
parenteaa1b143397fadcb31d69944ed69d6cf215be77d (diff)
downloadtdepim-ca705978d11b2e0bdcaf8186b0addff48d851483.tar.gz
tdepim-ca705978d11b2e0bdcaf8186b0addff48d851483.zip
Reorganize tdeioslave help handbooks, fix related protocol files and issues, update and add handbooks.
Diffstat (limited to 'tdeioslaves/imap4/CMakeLists.txt')
-rw-r--r--tdeioslaves/imap4/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/tdeioslaves/imap4/CMakeLists.txt b/tdeioslaves/imap4/CMakeLists.txt
deleted file mode 100644
index f427c2581..000000000
--- a/tdeioslaves/imap4/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-tde_import( libkmime )
-
-include_directories(
- ${CMAKE_BINARY_DIR}
- ${CMAKE_SOURCE_DIR}/libemailfunctions
- ${CMAKE_SOURCE_DIR}/libkmime
- ${CMAKE_SOURCE_DIR}/libtdepim
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-
-##### other data ################################
-
-install( FILES
- imap4.protocol imaps.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
-
-
-##### tdeio_imap4 (module) ########################
-
-tde_add_kpart( tdeio_imap4
- SOURCES
- imapcommand.cc imaplist.cc mailaddress.cc mimeheader.cc
- rfcdecoder.cc imap4.cc imapinfo.cc imapparser.cc
- mailheader.cc mimehdrline.cc mimeio.cc
- LINK emailfunctions-static kmime-shared tdeio-shared ${SASL_LIBRARY}
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)