summaryrefslogtreecommitdiffstats
path: root/plugins/radio/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2022-06-18 22:59:25 +0900
committerMichele Calgaro <[email protected]>2022-07-10 17:21:43 +0900
commitbc7518bdba609f90ee89de8b4e7ddaa1e567b1a8 (patch)
tree7a3f446098bbdaafc799fc97dd1bb998a2456252 /plugins/radio/CMakeLists.txt
parentf3116341d095d1b0237f7a36d1f3511759da7b03 (diff)
downloadtderadio-bc7518bdba609f90ee89de8b4e7ddaa1e567b1a8.tar.gz
tderadio-bc7518bdba609f90ee89de8b4e7ddaa1e567b1a8.zip
CMake conversion.
Signed-off-by: Michele Calgaro <[email protected]> Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'plugins/radio/CMakeLists.txt')
-rw-r--r--plugins/radio/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/radio/CMakeLists.txt b/plugins/radio/CMakeLists.txt
new file mode 100644
index 0000000..9877aba
--- /dev/null
+++ b/plugins/radio/CMakeLists.txt
@@ -0,0 +1,28 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/src
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### radio (translations)
+
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+
+
+##### radio (plugin)
+
+tde_add_kpart( libradio AUTOMOC
+ SOURCES radio-configuration.cpp radio-configuration-ui.ui radio.cpp
+ LINK tderadio-shared
+ DESTINATION ${LIB_INSTALL_DIR}/${PROJECT_NAME}/plugins
+)