summaryrefslogtreecommitdiffstats
path: root/plugins/recording/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2022-06-18 22:59:25 +0900
committerMichele Calgaro <[email protected]>2022-07-10 17:21:43 +0900
commitbc7518bdba609f90ee89de8b4e7ddaa1e567b1a8 (patch)
tree7a3f446098bbdaafc799fc97dd1bb998a2456252 /plugins/recording/CMakeLists.txt
parentf3116341d095d1b0237f7a36d1f3511759da7b03 (diff)
downloadtderadio-bc7518bdba609f90ee89de8b4e7ddaa1e567b1a8.tar.gz
tderadio-bc7518bdba609f90ee89de8b4e7ddaa1e567b1a8.zip
CMake conversion.
Signed-off-by: Michele Calgaro <[email protected]> Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'plugins/recording/CMakeLists.txt')
-rw-r--r--plugins/recording/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/plugins/recording/CMakeLists.txt b/plugins/recording/CMakeLists.txt
new file mode 100644
index 0000000..8d9d382
--- /dev/null
+++ b/plugins/recording/CMakeLists.txt
@@ -0,0 +1,33 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### recording (icons and translations)
+
+add_subdirectory( icons )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+
+
+##### recording (plugin)
+
+tde_add_kpart( librecording AUTOMOC
+ SOURCES
+ recording-configuration.cpp recording-configuration-ui.ui recording.cpp
+ recording-config.cpp reccfg_interfaces.cpp encoder.cpp recording-datamonitor.cpp
+ recording-monitor.cpp encoder_mp3.cpp encoder_ogg.cpp encoder_pcm.cpp
+
+ LINK tderadio-shared ${LAME_LIBRARIES} ${OGG_LIBRARIES} ${VORBIS_LIBRARIES}
+ ${VORBISFILE_LIBRARIES} ${VORBISENC_LIBRARIES} ${SNDFILE_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}/${PROJECT_NAME}/plugins
+)