summaryrefslogtreecommitdiffstats
path: root/tderadio3/convert-presets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tderadio3/convert-presets/Makefile.am')
-rw-r--r--tderadio3/convert-presets/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tderadio3/convert-presets/Makefile.am b/tderadio3/convert-presets/Makefile.am
new file mode 100644
index 0000000..179fa0d
--- /dev/null
+++ b/tderadio3/convert-presets/Makefile.am
@@ -0,0 +1,31 @@
+subdirs = po .
+
+bin_PROGRAMS = convert-presets
+
+convert_presets_SOURCES = convert-presets.cpp
+convert_presets_LDADD = $(LIB_TDEFILE) $(LIB_TDEUI) $(LIB_TDECORE)
+
+
+# this 10 paths are KDE specific. Use them:
+# kde_htmldir Where your docs should go to. (contains lang subdirs)
+# kde_appsdir Where your application file (.kdelnk) should go to.
+# kde_icondir Where your icon should go to.
+# kde_minidir Where your mini icon should go to.
+# kde_datadir Where you install application data. (Use a subdir)
+# kde_locale Where translation files should go to.(contains lang subdirs)
+# kde_cgidir Where cgi-bin executables should go to.
+# kde_confdir Where config files should go to.
+# kde_mimedir Where mimetypes should go to.
+# kde_toolbardir Where general toolbar icons should go to.
+# kde_wallpaperdir Where general wallpapers should go to.
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+METASOURCES = AUTO
+
+# the library search path.
+convert_presets_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o po/kradio-convert-presets.pot