summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 13:28:53 +0200
committerSlávek Banko <[email protected]>2021-07-26 13:29:05 +0200
commit159d1de537f82a473c14a98101aa6b905e885721 (patch)
tree0eee27106785008c5528bb15e36429775da401de /CMakeLists.txt
parent1d3b818b5e762f955e336e046478480a8965c7c3 (diff)
downloadtdesudo-159d1de537f82a473c14a98101aa6b905e885721.tar.gz
tdesudo-159d1de537f82a473c14a98101aa6b905e885721.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 168c258a6bac0510d26d82c6ceee79257dd9ecff)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9eb9ef..0249a82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,11 +69,14 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
-