summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 13:28:53 +0200
committerSlávek Banko <[email protected]>2021-07-26 13:28:53 +0200
commit168c258a6bac0510d26d82c6ceee79257dd9ecff (patch)
tree13638361b0dd0d5b20c66b835e26abe155424147 /CMakeLists.txt
parent94bcfcceea05db212b1ac6f636bea4ffb10587f6 (diff)
downloadtdesudo-168c258a6bac0510d26d82c6ceee79257dd9ecff.tar.gz
tdesudo-168c258a6bac0510d26d82c6ceee79257dd9ecff.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 643bae7..4793054 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,11 +69,14 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
-