summaryrefslogtreecommitdiffstats
path: root/src/tdesvnd/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2022-11-09 22:29:42 +0100
committerSlávek Banko <[email protected]>2022-11-09 22:29:42 +0100
commit976180bc549dc2cbb5875b2c6fba5cb807efc516 (patch)
treefd1035d8816462de5e2e78594bafb7fc8c0671d2 /src/tdesvnd/CMakeLists.txt
parent5d6073d6d93822a60274671b7a5ac5740f6ff8ea (diff)
downloadtdesvn-976180bc549dc2cbb5875b2c6fba5cb807efc516.tar.gz
tdesvn-976180bc549dc2cbb5875b2c6fba5cb807efc516.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Use common rules for build and install documentation. Added translation of .desktop files. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'src/tdesvnd/CMakeLists.txt')
-rw-r--r--src/tdesvnd/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/tdesvnd/CMakeLists.txt b/src/tdesvnd/CMakeLists.txt
index d1da1f3..a4f2a8c 100644
--- a/src/tdesvnd/CMakeLists.txt
+++ b/src/tdesvnd/CMakeLists.txt
@@ -28,7 +28,11 @@ link_directories(
set( ACTION_MENU "X-TDE-GetActionMenu=kded tdesvnd getActionMenu(KURL::List)" )
-configure_file (tdesvn_subversion.desktop.in ${CMAKE_CURRENT_BINARY_DIR}/tdesvn_subversion.desktop @ONLY )
-
-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/tdesvn_subversion.desktop DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus )
-install (FILES ${CMAKE_CURRENT_SOURCE_DIR}/tdesvnd.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+tde_create_translated_desktop(
+ SOURCE tdesvn_subversion.desktop.cmake
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+)
+tde_create_translated_desktop(
+ SOURCE tdesvnd.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+)