summaryrefslogtreecommitdiffstats
path: root/kweather/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2021-11-13 14:17:53 +0200
committerMavridis Philippe <[email protected]>2022-01-14 12:36:53 +0200
commit0e7033dd09c78eed673bfcde768483f6ad925ff7 (patch)
treea4f4484e6c154ff28c5d67697d6de976807fbf83 /kweather/CMakeLists.txt
parent5fea80f5693a74ee736300944c0c7204a663b92b (diff)
downloadtdetoys-0e7033dd09c78eed673bfcde768483f6ad925ff7.tar.gz
tdetoys-0e7033dd09c78eed673bfcde768483f6ad925ff7.zip
KWeather: updated icon handling.
The newly added class abstracts away icon names from the main code and has the ability to fall back to "safer" icon choices so as to ensure (if possible) icon theme consistency. Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'kweather/CMakeLists.txt')
-rw-r--r--kweather/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/kweather/CMakeLists.txt b/kweather/CMakeLists.txt
index dcf4722..b618585 100644
--- a/kweather/CMakeLists.txt
+++ b/kweather/CMakeLists.txt
@@ -36,7 +36,7 @@ tde_add_tdeinit_executable( kweatherreport AUTOMOC
##### kweatherservice (executable) ##############
tde_add_executable( kweatherservice AUTOMOC
- SOURCES main.cpp metar_parser.cpp
+ SOURCES main.cpp weather_icon.cpp metar_parser.cpp
weatherlib.cpp weatherservice.cpp
weatherservice.skel stationdatabase.cpp
sun.cpp weatherservice.stub
@@ -92,7 +92,7 @@ add_custom_command(
#
# tde_add_executable( metar_parser_test AUTOMOC
# SOURCES metar_parser_test.cpp metar_parser.cpp
-# stationdatabase.cpp sun.cpp
+# weather_icon.cpp stationdatabase.cpp sun.cpp
# )
#
# add_test( NAME metar_parser_test-test