summaryrefslogtreecommitdiffstats
path: root/kworldwatch/maps/depths/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-05-14 15:26:41 +0200
committerSlávek Banko <[email protected]>2020-05-15 11:55:19 +0200
commitd230ffe91600f31235f382cf8c0c5738a91101f9 (patch)
tree6b9198dabe0b78fe5e8ad6ed93232755310f5715 /kworldwatch/maps/depths/CMakeLists.txt
parentdcb03072211998dd141e3ade67c3d7bf7d8aa8f5 (diff)
downloadtdetoys-d230ffe91600f31235f382cf8c0c5738a91101f9.tar.gz
tdetoys-d230ffe91600f31235f382cf8c0c5738a91101f9.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 094853ca31a9dc5e619b0951953d4dc862a99e25)
Diffstat (limited to 'kworldwatch/maps/depths/CMakeLists.txt')
-rw-r--r--kworldwatch/maps/depths/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/kworldwatch/maps/depths/CMakeLists.txt b/kworldwatch/maps/depths/CMakeLists.txt
index 44405bc..2d3d0c5 100644
--- a/kworldwatch/maps/depths/CMakeLists.txt
+++ b/kworldwatch/maps/depths/CMakeLists.txt
@@ -9,8 +9,15 @@
#
#################################################
-install( FILES depths.desktop 400.jpg 800.jpg
+install(
+ FILES
+ 400.jpg 800.jpg
DESTINATION
${DATA_INSTALL_DIR}/kworldclock/maps/depths
)
+tde_create_translated_desktop(
+ SOURCE depths.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kworldclock/maps/depths
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kworldwatch-maps
+)